ELO Browser Information

ELO works best when used with Windows 7 or 8 on a desktop or laptop and one of the following browsers: Internet Explorer 8, Firefox 22, or Chrome 28 (or a higher version of any of these browsers).  

Using ELO on Macintosh OS X or on mobile devices may result in unexpected behavior.

 

Supported Browsers for E-Payment:

  • Microsoft Internet Explorer, versions 8.0 and above
  • Mozilla Firefox, versions 16.0 and above
  • Google Chrome

Also, you must have (1st party) Cookies enabled in your browser.  Error messages that are displayed if Cookies are not enabled:

  • Microsoft Internet Explorer: System Error
  • Mozilla Firefox: Cookies Disabled